code::blocks help (Linker Settings)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
master ageof
Newbie
*

Posts: 2
Joined: Nov 2012
Reputation: 0
#1
08-11-2012, 03:59 PM

Hello.
The idea of programming openGL from Prolog is very appealing. I downloaded the zip and followed the instruction (plOpenGL_quickstart.pdf) for Windows Vista. I didn't find some files (like libglut32.a, that I had to download from another web).
But now I have another problem: I don't find the file "plOpenGL.cbp", and I don't know how to perform the eighth point of the manual:

"8. Update Projects Linker Settings and Search Directories with your SWI-Prolog's installation paths."

Where are that option in Code::Blocks? I tried "properties" but there are no "Linker Settings" anywhere.

Can someone help me, please?
Reply
jan_tatham
Administrator
*******

Posts: 18
Joined: Apr 2012
Reputation: 0
#2
12-11-2012, 10:58 PM

Hi master ageof,

(08-11-2012, 03:59 PM)master ageof Wrote: But now I have another problem: I don't find the file "plOpenGL.cbp", and I don't know how to perform the eighth point of the manual:

The plOpenGL.cbp is in the codeblocks_win folder.

(08-11-2012, 03:59 PM)master ageof Wrote: "8. Update Projects Linker Settings and Search Directories with your SWI-Prolog's installation paths."

Where are that option in Code::Blocks? I tried "properties" but there are no "Linker Settings" anywhere.

To get to Linker Settings:

1. Go to Project > Properties...
2. Select the Project's build options... button located bottom right of the Project/targets options dialog.
3. Locate Linker Settings Tab (second tab).

Regards

JT
Reply
master ageof
Newbie
*

Posts: 2
Joined: Nov 2012
Reputation: 0
#3
22-11-2012, 07:45 PM

Thank you very much for your response. But now I have another problem...

(Well, first of all, I'd like to thank you for all the work you are doing here, for enhancing Prolog with OpenGL. I hope I can run my own graphic logic programs soon).

The problem happens when trying to run the examples provided, like "helloworld.pl". When I try to execute it, an Error message appears, saying that the the process "open_shared_object/3" (30th line of plopengl.pl) doesn't exist.
I located plOpengl.dll in the "bin" directory of my swi-prolog installation directory, and also in the same directory as "helloworld.pl", but the error persists.
Any idea?


PD: This is the reported error.
Quote:ERROR: c:/users/acer/desktop/plopengl-0.4.0_bin/plopengl/plopengl.pl:30:
'$open_shared_object'/3: No se encontró el proceso especificado.
(This post was last modified: 26-11-2012, 12:49 PM by master ageof.)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)